ecoEditor Workshop

Presentation to ecoinvent Users and Data Providers Meeting, Gothenburg, Sweden
2013.08.29

Tereza Lévová
& Emilia Moreno Ruiz
ecoinvent Centre
Content

- ecoEditor introduction
- Functions of the ecoEditor (explained directly in the software)
- Exercise - creating new dataset
Content

- Purpose
- Main features
- Data management in the ecoEditor
- How to start
- Opening the ecoEditor for the 1st time
- All the functions explained directly in the ecoEditor
Purpose

• The ecoEditor is a freeware used by the ecoinvent Centre for
  □ creating datasets
  □ editing datasets
  □ reviewing datasets
  □ uploading datasets to the ecoinvent database
Main features

- Use of the ecoSpold2 format -> new possibilities (parameters, variable names, formulas, etc.)
- Undefined multi-output dataset template -> guidance in collection of the necessary data
- Build-in help
- Validation of the new dataset -> more than 300 build-in rules which ensure the completeness and quality of the dataset
Format of the datasets

- Undefined multi-output dataset template
Data management in the ecoEditor

- During installation so called **master data** are downloaded and stored in your computer.

- The database is accessed **online** - each dataset is downloaded separately, the datasets are not stored in your computer unless you do so manually.

- The datasets you create in the ecoeditor are **not visible** to the ecoinvent Centre unless you submit them.
How to start

- Download the installation file from the ecoinvent webpage and install the ecoEditor
- Start the ecoEditor
- Go to Extras -> Account Management -> Create account (Update EcoQuery Account) -> Register Data Provider Account + fill in all the information
- Wait for the approval of your account by the ecoinvent Centre
Opening the ecoEditor for the 1st time

- Horizontal menu, classic windows style

- Read about the ecoEditor from the guide, Help -> Show ecoEditor

- Go to File -> Update Master Data -> download of the latest master data

- All functions explained directly in ecoeditor ...
Example dataset

- diethyl ether production /GLO
Symbols, icons, etc.

- The “star” ⭐ means, that there is **more text**, that visible in the current view.

- “Three dots” ⋯ is an icon, which can be clicked on and a **new window** will open.

- Text in **black** was entered by the data provider and can be edited.

- Text in **grey** was generated automatically during submission and cannot be edited.
ecoEditor exercise

Presentation to ecoinvent Users and Data Providers Meeting, Gothenburg, Sweden
2013.08.29

Tereza Lévová & Emilia Moreno Ruiz
ecoinvent Centre
Content

- Regional versus global (GLO) dataset
- Creation of new dataset “From Scratch” in the ecoEditor
- Activity Description and Modelling and Administrative
- Exchanges - new product, amounts, mathematical relation, etc.
- Validation - online, offline
- Creation of new dataset “From Existing Dataset”
- Review process
Regional versus global (GLO) datasets

- Regional datasets cannot be submitted without global (GLO) dataset

- Procedure of submitting both regional and GLO datasets:
  - Manually
  - Parent-child relationship
  - Automatic creation of the GLO dataset
Regional versus global (GLO) datasets

- Manually

  - When unique data for both the GLO and the regional datasets are available
  - Both the GLO and the regional datasets are entered manually

  -> simple, less validation errors

  -> changes in the future must be done manually as well
Regional versus global (GLO) datasets

- Parent-child relationship
  - When only part of the data are unique in the regional dataset and there is a probability they will change in the future
  - GLO dataset is created first and regional dataset is created as its child

  -> more validation rules

  -> all changes in the parent in the future will automatically be updated in the child
Regional versus global (GLO) datasets

- Automatic creation of the GLO dataset
  - The regional dataset(s) is created first and the GLO dataset is created using the automatic function (because no unique data are available)
  - The GLO is created as a weighted average (by production volume) of the regional datasets

-> save time, less validation errors

-> changes in the future can be done either manually or using again this function
New Dataset: mango production / IN

- File -> New -> New Dataset From File -> From Scratch

- Activity Name: mango production

- Geography: India (IN)

- Time Period: 1/1/2008 to 12/31/2013

- File -> Save Dataset As ...
Activity Description

• General Comment:

  This dataset represents mango production in India. Yield = 2.5 t/ha, duration of one cycle: 12 months, etc.

• Included Activities Start:

  From maintenance of the orchards after harvest of the previous crop.

• Included Activities End:

  This activity ends with harvest and storage.
Activity Description

- Classifications, System: Value
  - ISIC rev.4 ecoinvent: 0.125: Growing of other tree and bush fruits and nuts

- Technology level:
  - Current

- Technology, Comment:
  - Average of all different technologies of mango production in India.
Modelling and Administrative

- Representativeness, Percent:
  - 75%

- Representativeness, Sampling Procedure:
  - The data were partially directly from the farmers and combined with the information provided by the Association of Indian Mango Producers.

- Data Generator and Publication, Person

- Data Generator and Publication, Data Published In
Exchanges - new product

- Exchanges -> Add -> Intermediate Exchange -> Create Exchange
- Name: mango
- Variable Name: mango
- Unit: kg
- Classification: 0131: Tropical and subtropical fruits
- Properties:
  - wet mass = 1kg, dry mass = 0.17kg,
  - water in wet mass = wet mass - dry mass = 0.83kg
  - water content = water in wet mass/dry mass = 4.88kg
  - carbon content, fossil = 0kg, carbon content, non-fossil = 0.47kg
Mass and carbon compulsory properties

- Wet mass (WM)
  - Dry mass (DM)
    - Water in Wet mass (WWM)
  - Water content (U)
    - Water in Wet mass (WWM)
    - Dry mass (DM)
Mass and carbon compulsory properties

- Carbon:
  - fossil
  - non-fossil
## Interrelated properties

<table>
<thead>
<tr>
<th>Wet mass (WM)</th>
<th>Dry mass (DM)</th>
<th>Water mass (W)</th>
<th>Water content (U)</th>
</tr>
</thead>
<tbody>
<tr>
<td>WM</td>
<td>WM-W</td>
<td>W</td>
<td>W/(WM-W)</td>
</tr>
<tr>
<td>WM</td>
<td>DM</td>
<td>WM-DM</td>
<td>(WM-DM)/DM</td>
</tr>
<tr>
<td>WM</td>
<td>WM/(1+U)</td>
<td>U*WM/(1+U)</td>
<td>U</td>
</tr>
<tr>
<td>W+DM</td>
<td>DM</td>
<td>W</td>
<td>W/DM</td>
</tr>
<tr>
<td>(W/U)+W</td>
<td>W/U</td>
<td>W</td>
<td>U</td>
</tr>
<tr>
<td>(1+U)*DM</td>
<td>DM</td>
<td>DM*U</td>
<td>U</td>
</tr>
</tbody>
</table>
### Compulsory properties: units

<table>
<thead>
<tr>
<th></th>
<th>natural gas, high pressure (m³)</th>
<th>palm fruit bunch (kg)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Wet Mass (WM) (kg/unit of the flow)</td>
<td>0.84</td>
<td>1</td>
</tr>
<tr>
<td>Dry Mass (DM) (kg/unit of the flow)</td>
<td>0.84</td>
<td>0.53</td>
</tr>
<tr>
<td>Water in Wet Mass (WWM) (kg/unit of the flow)</td>
<td>0</td>
<td>0.47</td>
</tr>
<tr>
<td>Carbon content, fossil (kg C/kg DM)</td>
<td>0.60</td>
<td>0</td>
</tr>
<tr>
<td>Carbon content, non-fossil (kg C/kg DM)</td>
<td>0</td>
<td>0.59</td>
</tr>
</tbody>
</table>
## Exchanges - amounts

<table>
<thead>
<tr>
<th>Type</th>
<th>Name</th>
<th>Unit</th>
<th>Compartment</th>
<th>Subcompartment</th>
<th>Amount</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reference Product</td>
<td>mango</td>
<td>kg</td>
<td></td>
<td></td>
<td>1</td>
</tr>
<tr>
<td>FromTechnosphere</td>
<td>irrigation</td>
<td>m³</td>
<td></td>
<td></td>
<td>0</td>
</tr>
<tr>
<td>FromTechnosphere</td>
<td>phosphate fertiliser, as P2O5</td>
<td>kg</td>
<td></td>
<td></td>
<td>0.00746</td>
</tr>
<tr>
<td>FromTechnosphere</td>
<td>fertilising, by broadcaster</td>
<td>ha</td>
<td></td>
<td></td>
<td>0.000418</td>
</tr>
<tr>
<td>FromTechnosphere</td>
<td>pesticide, unspecified</td>
<td>kg</td>
<td></td>
<td></td>
<td>8.82E-05</td>
</tr>
<tr>
<td>ToEnvironment</td>
<td>Phosphate</td>
<td>kg</td>
<td>water</td>
<td>ground-</td>
<td>2.09E-06</td>
</tr>
<tr>
<td>ToEnvironment</td>
<td>Pesticides, unspecified</td>
<td>kg</td>
<td>soil</td>
<td>agricultural</td>
<td>0</td>
</tr>
<tr>
<td>FromEnvironment</td>
<td>Transformation, to permanent crop, irrigated</td>
<td>m²</td>
<td>natural resource</td>
<td>land</td>
<td>0.299</td>
</tr>
<tr>
<td>FromEnvironment</td>
<td>Transformation, from permanent crop, irrigated</td>
<td>m²</td>
<td>natural resource</td>
<td>land</td>
<td>0.5</td>
</tr>
<tr>
<td>FromEnvironment</td>
<td>Occupation, permanent crop, irrigated</td>
<td>m²*year</td>
<td>natural resource</td>
<td>land</td>
<td>0.299</td>
</tr>
<tr>
<td>Name</td>
<td>Variable Name</td>
<td>Unit</td>
<td>Amount</td>
<td>Variable Name</td>
<td>Mathematical relation</td>
</tr>
<tr>
<td>----------------------</td>
<td>---------------</td>
<td>---------------</td>
<td>--------</td>
<td>------------------------</td>
<td>-----------------------</td>
</tr>
<tr>
<td>yield, agriculture</td>
<td>yield_agriculture</td>
<td>metric ton/ha</td>
<td>2.4</td>
<td>yield_mango_production</td>
<td>6*0.4</td>
</tr>
<tr>
<td>irrigation demand</td>
<td>irrigation_demand</td>
<td>m3/ha/year</td>
<td>728</td>
<td>irrigation_demand_mango</td>
<td>(100<em>140</em>52)/1000</td>
</tr>
</tbody>
</table>
Exchanges - Mathematical Relation

- The amount of pesticide, unspecified released to soil is equal to the amount of pesticide, unspecified which enters the activity.

- The amount of irrigation needed is calculated using parameters.

<table>
<thead>
<tr>
<th>Type</th>
<th>Name</th>
<th>Unit</th>
<th>Amount</th>
<th>Variable Name</th>
<th>Mathematical Relation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reference Product</td>
<td>mango</td>
<td>kg</td>
<td>1</td>
<td></td>
<td></td>
</tr>
<tr>
<td>FromTechnosphere</td>
<td>irrigation</td>
<td>m3</td>
<td>1.7472</td>
<td></td>
<td>(yield_mango_production*irrigation_demand_mango)/1000</td>
</tr>
<tr>
<td>FromTechnosphere</td>
<td>pesticide, unspecified</td>
<td>kg</td>
<td>8.82E-05</td>
<td>pesticide_unspecified_input</td>
<td></td>
</tr>
<tr>
<td>ToEnvironment</td>
<td>Pesticides, unspecified</td>
<td>kg</td>
<td>8.82E-05</td>
<td>pesticide_unspecified_to_soil</td>
<td>pesticide_unspecified_input</td>
</tr>
</tbody>
</table>
# Exchanges - Uncertainty, Source, Comment

<table>
<thead>
<tr>
<th>Type</th>
<th>Name</th>
<th>Unit</th>
<th>Uncertainty</th>
<th>Source</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reference Product</td>
<td>mango</td>
<td>kg</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>From Technosphere</td>
<td>irrigation</td>
<td>m3</td>
<td>0.0006 (2,2,2,2,2)</td>
<td></td>
<td>Calculated based on literature data (SOURCE). See the mathematical relation and parameters and their comments.</td>
</tr>
<tr>
<td>From Technosphere</td>
<td>phosphate fertiliser, as P2O5</td>
<td>kg</td>
<td>0.0006 (2,2,2,2,2)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>From Technosphere</td>
<td>fertilising, by broadcaster</td>
<td>ha</td>
<td>0.0006 (2,2,2,2,2)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>From Technosphere</td>
<td>pesticide, unspecified</td>
<td>kg</td>
<td>0.0006 (2,2,2,2,2)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>To Environment</td>
<td>Phosphate</td>
<td>kg</td>
<td>0.04 (2,2,2,2,2)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>To Environment</td>
<td>Pesticides, unspecified</td>
<td>kg</td>
<td>0.04 (2,2,2,2,2)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>From Environment</td>
<td>Transformation, to permanent crop, irrigated</td>
<td>m2</td>
<td>0.12 (2,2,2,2,2)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>From Environment</td>
<td>Transformation, from permanent crop, irrigated</td>
<td>m2</td>
<td>0.12 (2,2,2,2,2)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>From Environment</td>
<td>Occupation, permanent crop, irrigated</td>
<td>m2*year</td>
<td>0.04 (2,2,2,2,2)</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Exchanges - Production Volume

- Annual Production Volume (APV) need to be filled only for the Reference Product and By-products, if there are some.

- APV represent the amount of the reference product produced in a given technology and geography.

- The unit of the APV is identical with the unit of the reference product.

<table>
<thead>
<tr>
<th>Type</th>
<th>Name</th>
<th>Unit</th>
<th>Annual Production Volume</th>
<th>Production Volume Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reference Product</td>
<td>mango</td>
<td>kg</td>
<td>16.34E9</td>
<td>Literature value (SOURCE) for the year 2010. The Indian production represents 42% of the global production of mangoes.</td>
</tr>
</tbody>
</table>
Exchanges - Activity Link

- When it is clear from where the concrete product comes from
  - phosphate fertiliser, as P2O5 -> Activity Link -> set to “citric acid production” RER, meaning I know the fertilizer I am using comes from this concrete activity; and this activity can adapt its production to my needs

- Modelling challenges
  - The transport from the market must be included directly in the production activity
  - The amount of phosphate must be lower than what is the activity to which it links producing
Validation - offline

- Dataset is being validated offline against the validation rules which are build in the ecoEditor

- *File -> Validate Dataset* ✔

- *Modelling and Administrative, Review, Details*

  - Validation failed with errors: The sum of all land use transformations from (0.0.5 m2) must equal the sum of all output transformations to (0.299 m2).

- *Modelling and Administrative, Review, Other Details*

  - Balances; dry mass, wet mass, carbon content, etc.
Validation - online

- Dataset is being validated online against the other datasets already present in the database and against the online validation rules

- **File** -> **Submit Datasets for Validation** ...

- **Tasks** -> **Refresh** -> **Right Click** -> **View Validation Results**

- **Modelling and Administrative, Review, Details**

  Validation failed with errors: Non-global datasets cannot be uploaded unless a global dataset (for the same activity name, time period and macro-economic scenario) exists in the database or is uploaded together with the non-global dataset. No matching activities found.
Validation - online

- Dataset is being validated online against the other datasets already present in the database and against the online validation rules

- *File -> Submit Datasets for Validation ...*

- *Tasks -> Refresh -> Right Click -> View Validation Results*

- *Modelling and Administrative, Review, Details*

  - Validation failed with errors: Non-global datasets cannot be uploaded unless a global dataset (for the same activity name, time period and macro-economic scenario) exists in the database or is uploaded together with the non-global dataset. No matching activities found.
New Dataset: mango production / CN

- File -> New -> New Dataset From File -> From Existing Dataset

- Dataset: Open mango production /IN

- Activity Name: mango production

- Geography: China (CN)

- Time Period: 1/1/2008 to 12/31/2013

- File -> Save Dataset As ...
<table>
<thead>
<tr>
<th>Name</th>
<th>Variable Name</th>
<th>Unit</th>
<th>Amount</th>
<th>Variable Name</th>
<th>Mathematical relation</th>
<th>Uncertainty</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>yield, agriculture</td>
<td>yield_agriculture</td>
<td>metric ton/ha</td>
<td>3.2</td>
<td>yield_mango_production</td>
<td>8*0.4</td>
<td>0.0006 (2,2,2,2,2)</td>
<td>Calculated value based on literature. The yield of mango production in India is 8t/acre (SOURCE). 1 acre = 0.4 ha.</td>
</tr>
<tr>
<td>irrigation demand</td>
<td>irrigation_demand</td>
<td>m3/ha/year</td>
<td>500</td>
<td>irrigation_demand_mango</td>
<td>(80<em>120</em>52)/1000</td>
<td>0.0006 (2,2,2,2,2)</td>
<td>Calculated value based on literature. 80 l/plant/week is the irrigation requirement of one mango plant grown in India (SOURCE). 120 plant/ha is the number of plants grown per one hectare of land (SOURCE). 52 weeks/year. 1000 l/m3.</td>
</tr>
</tbody>
</table>
Exchanges - Mathematical Relation

- The amount of pesticide, unspecified released to soil is equal to the amount of pesticide, unspecified which enters the activity.
- The amount of irrigation needed is calculated using parameters.

<table>
<thead>
<tr>
<th>Type</th>
<th>Name</th>
<th>Unit</th>
<th>Amount</th>
<th>Variable Name</th>
<th>Mathematical Relation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reference Product</td>
<td>mango</td>
<td>kg</td>
<td>1</td>
<td></td>
<td></td>
</tr>
<tr>
<td>FromTechnosphere</td>
<td>irrigation</td>
<td>m3</td>
<td>1.597</td>
<td></td>
<td>(yield_mango_production*irrigation_demand_mango)/1000</td>
</tr>
<tr>
<td>FromTechnosphere</td>
<td>pesticide, unspecified</td>
<td>kg</td>
<td>8.82E-05</td>
<td>pesticide_unspecified_input</td>
<td></td>
</tr>
<tr>
<td>ToEnvironment</td>
<td>Pesticides, unspecified</td>
<td>kg</td>
<td>8.82E-05</td>
<td>pesticide_unspecified_to_soil</td>
<td>pesticide_unspecified_input</td>
</tr>
</tbody>
</table>
## Exchanges - amounts

<table>
<thead>
<tr>
<th>Type</th>
<th>Name</th>
<th>Unit</th>
<th>Compartiment</th>
<th>Subcompartiment</th>
<th>Amount</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reference Product</td>
<td>mango</td>
<td>kg</td>
<td></td>
<td></td>
<td>1</td>
</tr>
<tr>
<td>FromTechnosphere</td>
<td>irrigation</td>
<td>m3</td>
<td></td>
<td></td>
<td>1.597</td>
</tr>
<tr>
<td>FromTechnosphere</td>
<td>phosphate fertiliser, as P2O5</td>
<td>kg</td>
<td></td>
<td></td>
<td>0.00746</td>
</tr>
<tr>
<td>FromTechnosphere</td>
<td>fertilising, by broadcaster</td>
<td>ha</td>
<td></td>
<td></td>
<td>0.000418</td>
</tr>
<tr>
<td>FromTechnosphere</td>
<td>pesticide, unspecified</td>
<td>kg</td>
<td></td>
<td></td>
<td>5E-05</td>
</tr>
<tr>
<td>ToEnvironment</td>
<td>Phosphate</td>
<td>kg</td>
<td>water</td>
<td>ground-</td>
<td>2.09E-06</td>
</tr>
<tr>
<td>ToEnvironment</td>
<td>Pesticides, unspecified</td>
<td>kg</td>
<td>soil</td>
<td>agricultural</td>
<td>5E-05</td>
</tr>
<tr>
<td>FromEnvironment</td>
<td>Transformation, to permanent crop, irrigated</td>
<td>m2</td>
<td>natural resource</td>
<td>land</td>
<td>0.299</td>
</tr>
<tr>
<td>FromEnvironment</td>
<td>Transformation, from permanent crop, irrigated</td>
<td>m2</td>
<td>natural resource</td>
<td>land</td>
<td>0.299</td>
</tr>
<tr>
<td>FromEnvironment</td>
<td>Occupation, permanent crop, irrigated</td>
<td>m2*year</td>
<td>natural resource</td>
<td>land</td>
<td>0.299</td>
</tr>
</tbody>
</table>
Exchanges - Production Volume

• Annual Production Volume (APV) need to be filled only for the Reference Product and By-products, if there are some

• APV represent the amount of the reference product produced in a given technology and geography

• The unit of the APV is identical with the unit of the reference product

<table>
<thead>
<tr>
<th>Type</th>
<th>Name</th>
<th>Unit</th>
<th>Annual Production Volume</th>
<th>Production Volume Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reference Product</td>
<td>mango</td>
<td>kg</td>
<td>4.35E9</td>
<td>Literature value (SOURCE) for the year 2010. The Chinese production represents 11% of the global production of mangoes.</td>
</tr>
</tbody>
</table>
New Dataset: mango production / GLO

- Regional datasets cannot be submitted without global (GLO) dataset

- There are several types of GLO
  - Original data for the GLO dataset are available -> dataset to be created as any other unique dataset, possibility of using parent-child relationship
  - No original data are available -> dataset to be created using automatic function in the ecoeditor (the data provider can choose if he/she wants to claim the authorship for this dataset)

- The annual production volume of the global dataset have to be always entered
The review process

- Before the submission to the review, the data provider must:
  - Make sure that there are no validation errors
  - Make sure, that most of the validation warnings are justifiable
  - Reach an agreement with the ecoinvent Centre management, that the dataset should be submitted

- *File -> Submit Datasets For Review* + follow the progress of the review in the *Tasks* sheet
Thank you for your attention!

Tereza Lévová
Data Analyst
ecoinvent Centre
levova@ecoinvent.org, support@ecoinvent.org

Trust in Transparency!